Groups are not clickable from Groups Page in Atlassian Administration

Incident Report for Guard

Resolved

We have implemented the fix and the group page in the Admin Hub is now functioning as expected.
Posted Feb 18, 2026 - 11:30 UTC

Monitoring

We have identified the root cause, and fix has been rolled out to mitigate the problem. We are monitoring the progress.
Posted Feb 18, 2026 - 11:28 UTC
This incident affected: Domain Claims, SAML-based SSO, User Provisioning, Account Management, Audit Logs, Signup, API tokens and Guard Premium (Data Classification, Data Security Policies, Guard Detect).